re = /(?:
\G(?!\A)
|
{ (?=[^}]* })
|
\[ (?=[^]]* ])
)
\K
[A-G] [^]A-G}]*/x
str = '{A\'\'BsCb}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end