using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<form.*?action=""([^""]*)"".*?>";
string input = @"<form id=""loginForm"" name=""loginForm"" method=""post"" action=""M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB"">
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}