const regex = new RegExp('<a\\s+(?![^>]*rel\\s*=\\s*([\\'"])\\s*nofollow\\s*\\1)[^>]*href\\s*=\\s*(["\\'])http://www.mysite.com[][\\w-.~:/?#@!%$&\\'()*+,;=]*\\2[^>]*>', 'g')
const str = `<a ... href="http://www.mysite.com/xyz...." ... >
<a ... href="http://www.mysite.com/xyz...." rel='nofollow' ... >
<a ... href="http://www.NOTmysite.com" ... >
<a ... href="http://www.mysite.com" rel='foobar'... >
<a class="use_same_protocol" href="//www.mysite.com" >
<!-- This used to great <a ... href="http://www.mysite.com/xyz...." ... > -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}