package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\?(?:php)?
(?:(?!\?>)[\s\S])*
(?:\?>)?`)
var str = `<?php foo(); ?>
<abc>
<? foo(); ?>
<?php
foo();
bar();
?>
foo();
bar();
<? //also short open tag
foo();
bar();
?><?php
foo();
bar();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}