$re = '/\b\w+\b\$(?!\\\\)/';
$str = 'di$\\>i/<d10i$>""=ssalc i<01$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);