$re = '~(.)\\\\1{2,}~u';
$str = '$subject = \'fffffffffffff\' ;
$subject = \'chat\' ;
$subject = \'fffffffffffffffbbbc\' ;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);