const regex = /\[[^\[]*product[^\]]*\]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^\\[]*product[^\\]]*\\]', 'ig')
const str = `[products-tab collection="frontpage,new,all-1" title="BEST SELLING" nav="true" style="product-loop-swatch" rows="2" items="8" header="style-1"]
[products-deal product="apple-iphone-se,armani-exchange-brown-leather-watch-ax2181" title="DEAL OF THE DAY"]
[blog blog="news" desc="If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!" style="style-2"]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}