import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+):\\s*TextConst\\s*ENU\\s*=\\s*'(.*)',\\s*ENG\\s=\\s'(.*)';";
final String string = "Regular Expression No.1 --> (.+):\\s*TextConst\\s*ENU\\s*=\\s*'(.*)',\\s*ENG\\s=\\s'(.*)';\n"
+ "------------------------------------------------------------------------------------\n\n"
+ "TxtLineText: TextConst ENU = 'Line %1: ', ENG = 'Line %1: ';\n"
+ "TxtNoLinesToProcess: TextConst ENU = 'There are no lines to process', ENG = 'There are no lines to process';\n\n\n\n"
+ "Regular Expression No.2 --> (.+):\\s*TextConst\\s*ENU\\s*='(.*)'\\s*,\\s*ENG='(.*)'\\s*;\n"
+ "-----------------------------------------------------------------------------------\n\n"
+ "TxtPurchaseWorksheetNosCode : TextConst ENU='PURCH WKSH',ENG='PURCH WKSH';\n"
+ "TxtPurchaseWorksheetNosDescription : TextConst ENU='Purchase Worksheet',ENG='Purchase Worksheet';\n"
+ "TxtPurchaseWorksheetNosStartingNo : TextConst ENU='PW000001',ENG='PW000001';\n"
+ "TxtSalesWorksheetNosCode : TextConst ENU='SALES WKSH',ENG='SALES WKSH';\n"
+ "TxtSalesWorksheetNosDescription : TextConst ENU='Sales Worksheet',ENG='Sales Worksheet';\n"
+ "TxtSalesWorksheetNosStartingNo : TextConst ENU='SW000001',ENG='SW000001';";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}