package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\s+(?<Data>[^\s]*)\s.*`)
var str = `00006 GLP1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}