#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(a)(?=(?:.*(b))?)(?=(?:.*(c))?)(?=(?:.*(d))?)"
Local $sString = "a" & @CRLF & _
"a b" & @CRLF & _
"a c" & @CRLF & _
"a b c" & @CRLF & _
"a c b" & @CRLF & _
"a b c d" & @CRLF & _
"a d b c" & @CRLF & _
"a c d b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")