// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(here\b.*?)\bstring\b").unwrap();
let string = "this is a string test with a lot of string words here another string string there string here string.";
let substitution = "$1anotherString";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}