import Foundation
let pattern = #"\b(here\b.*?)\bstring\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"this is a string test with a lot of string words here another string string there string here string."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1anotherString"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}