# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\"\;\,\$\{\}\_\(\)\.\!\'\-\:\s\/\<\>\w\näöüÄÖÜèéà@]*))@endif"
test_str = ("@if('0' == '0')\n"
" <div id=\"alert\" class=\"alert alert-danger\" style=\"display: inline-block\">fgh</div>\n"
"@endif\n"
"<form method=\"post\">\n"
"<button id=\"startLogik\" class=\"button\" type=\"submit\" name=\"start\">fgh</button>\n"
"</form>\n"
"@if('0' == '1')\n"
" <script type=\"text/javascript\">\n"
" Logik_SrvBsy = \"bsy\";\n"
" GetClientName();\n"
" Logik_Init(\"\", \"\", \"web\",\"test\",\"Start\");\n"
" Logik_SPar_fx(\"WEB_LOGIN.EMAIL\", \"mail@mail\");\n"
" Logik_SPar_fx(\"WEB_LOGIN.WEBID\", \"cvb\");\n"
" Logik_SPar_fx(\"WEB_LOGIN.LANG\", \"cvb\");\n"
" Logik_Exec_fx(\"Start\");\n"
"</script>\n"
"@endif")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.