const regex = /^(?=.*\d)(?=.*[^a-zA-Z0-9\n])(?=.*[a-z])(?=.*[A-Z])(?!.*([a-zA-Z0-9])\1\1).{6,20}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)(?=.*[^a-zA-Z0-9\\n])(?=.*[a-z])(?=.*[A-Z])(?!.*([a-zA-Z0-9])\\1\\1).{6,20}$', 'gm')
const str = `asA112!
asA111@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}