$re = '/\^CV_(\w+)?(?:-(\w+))?-Base/m';
$str = 'EnglUS^CV_Common-Concierge-Base^0^0^0
EnglUS^CV_Common-Base^0^0^0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);