using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mul\((\d{1,3}),(\d{1,3})\)";
string input = @"xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}