using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li>[\w\s]*word[\w\s]*<\/li>";
string input = @"<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word</li>
<li>word</li>
<li> word</li>
<li>qweqwe sad qwe </li>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}