package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<li>[\w\s]*word[\w\s]*<\/li>`)
var str = `<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word</li>
<li>word</li>
<li> word</li>
<li>qweqwe sad qwe </li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}