// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<li>[\w\s]*word[\w\s]*<\/li>").unwrap();
let string = "<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word </li>
<li>qweqwe sad qwe word</li>
<li>word</li>
<li> word</li>
<li>qweqwe sad qwe </li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}