# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src=\"\K.*(\\/info[^']*)'[^\"]*/http:\/\/example.com$1/gm;t' <<< "src=\"http://example.com/javascript:gallery('/info/2005/image.jpg',383,550)\""