import Foundation
let pattern = #"src=\"\K.*(\/info[^']*)'[^\"]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"src="http://example.com/javascript:gallery('/info/2005/image.jpg',383,550)""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://example.com$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)