import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Building: )[A-Z]+(?: (?!UNIT\\b)[A-Z]+\\b)*";
final String string = "Building: BUILDING ONE 15 [building name followed by unit number]\n"
+ "Optional preceding text Building: BUILDING ONE 15 [preceding text, then building name followed unit number]\n"
+ "Building: BUILDING ONE UNIT 15 [building name followed by word UNIT and unit number]\n"
+ "Building: BUILDING ONE Floor 2 [building name followed by mixed case word]\n"
+ "Grounds: OPEN SPACE WEST Section 3 [not a building - return nothing]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}