import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:#capture)(\\s*batman (\\d+) batman\\s*)*(?:#capture)";
final String string = "#capture\n"
+ "batman 12345 batman\n"
+ "batman 234 batman\n"
+ "batman 35655 batman\n"
+ "batman 1311 batman\n"
+ "#capture\n\n"
+ "#others\n"
+ "batman 12345 batman\n"
+ "batman 234 batman\n"
+ "batman 35655 batman\n"
+ "batman 1311 batman\n"
+ "#others";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}