package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<\/?span>)(\w+)`)
var str = `<span>Name</span>Message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}