re = /order.*?(\d+)/m
str = 'orderId=669819528
url1\\order679638797
url2\\orders\\result691272565
url2\\blahblah&orderId=685442897
url4\\orderId=671554945
otherone
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end