$re = '/^(?(?!SS|WW)[A-HJ-NP-TV-Z]{2})[0-9]{3}(?(?!SS)[A-HJ-NP-TV-Z]{2})$/';
$str = 'AA000AA
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);