re = /^-?(\d{5}|\d{2}(?=\d*\.\d*)[\d.]{3}\d)$/m
str = '10.095
100.95
1009.5
10095
100955
1.0095
-1.0095
0.1009
0.10009'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end