Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
^[A-Za-z0-9\-]{5,30}$
`
gm
Input 1
1
New
98b8d46a4484729c712a79d7473bdc23 98b8d46a4484729c712a79d7473bdc 5-35XES36D 20160401150146120SME099935