package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9\-]{5,30}$`)
var str = `98b8d46a4484729c712a79d7473bdc23
98b8d46a4484729c712a79d7473bdc
5-35XES36D
20160401150146120SME099935`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}