import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "font-family:\\s*'([^']*)'";
final String string = "@font-face {\n"
+ " font-family: 'fancy-icons';\n"
+ " src:\n"
+ " url('#{$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype'),\n"
+ " url('#{$icon-font-path}/fancy-icons.woff?p3owtd') format('woff'),\n"
+ " url('#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');\n"
+ " font-weight: normal;\n"
+ " font-style: normal;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}