#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[1-9][2-9][0-9]\d{3,}|[1-9]\d{6,}"
Local $sString = "111" & @CRLF & _
"55" & @CRLF & _
"954" & @CRLF & _
"955" & @CRLF & _
"1000" & @CRLF & _
"0004" & @CRLF & _
"12000" & @CRLF & _
"120" & @CRLF & _
"999999" & @CRLF & _
"100000" & @CRLF & _
"120000" & @CRLF & _
"1200000" & @CRLF & _
"1000000" & @CRLF & _
"123456" & @CRLF & _
"222222" & @CRLF & _
"Log text: ajdlksjfds 120000 alskjdflskdf" & @CRLF & _
"" & @CRLF & _
"Log text2: ajsldkfjsd 12000 alskdjflskdj" & @CRLF & _
"" & @CRLF & _
"Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")