use strict;
my $str = '111
55
954
955
1000
0004
12000
120
999999
100000
120000
1200000
1000000
123456
222222
Log text: ajdlksjfds 120000 alskjdflskdf
Log text2: ajsldkfjsd 12000 alskdjflskdj
Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf
';
my $regex = qr/[1-9][2-9][0-9]\d{3,}|[1-9]\d{6,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}