// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[1-9][2-9][0-9]\d{3,}|[1-9]\d{6,}").unwrap();
let string = "111
55
954
955
1000
0004
12000
120
999999
100000
120000
1200000
1000000
123456
222222
Log text: ajdlksjfds 120000 alskjdflskdf
Log text2: ajsldkfjsd 12000 alskdjflskdj
Log text 3: alskdjflskdjf 1000000 aslkdjflskdjf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}