package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9]\d{3,}|9[6-9]\d|9[5-9]{2}`)
var str = `111
55
954
955
1000
0004
999999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}