package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$?(\d{1,3},(\d{3},)*\d{3}|\d+)(.\d{1,4})?$`)
var str = `2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}