// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$?(\d{1,3},(\d{3},)*\d{3}|\d+)(.\d{1,4})?$").unwrap();
let string = "2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}