$re = '/img(?![^<]*<\/img>)/';
$str = '<img href=\\"#\\">112233test112233</img>123img123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);