use strict;
my $str = 'object-group network FTP
description FTP Access
network-object host BCD1
network-object host BCD2
object-group network NTP
description NTP Access
network-object host ABC1
network-object host ABC2
network-object host ABC3
object-group service sample_service tcp
description Ports 1 2 3
port-object range 80 81
port-object eq pop3
port-object eq imap4
port-object range 443 444
object-group service 8080 tcp
description Servers';
my $regex = qr/\bobject-group\b\S*(?:\s+(?!object-group\b)\S*)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}