$re = '/^([1-9][0-9]|[0-9][1-9])[0-9]{4,}$/m';
$str = '00123456
12345
01123456
12123456
80123456
11123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);