$re = '/\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z/';
$str = '2000-01-01T01:01:01Z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);