// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}").unwrap();
let string = "#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}