#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*[\s\S]*?\*\/"
Local $sString = "/*@comment" & @CRLF & _
"" & @CRLF & _
" @title: Buttons" & @CRLF & _
" @name: block-name" & @CRLF & _
" @category: Category name > Sub category" & @CRLF & _
" @description: This is the description of the element" & @CRLF & _
" @html:" & @CRLF & _
" <div class="block-name"></div>" & @CRLF & _
"" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")