package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`A\w*e\s`)
var str = `Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]
(IUPAC: Disilver sulfide)
Acetamide (1974-039) 10.AA.20 [21] [22] [23]
(IUPAC: Acetic acid amide)
Achalaite (2013-103) 04.?? [24] [no] [no]
Achavalite (Y: 1939`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}