# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\d{1,2}\b(?![^\/\r\n]\/)"
test_str = ("ID Flag\n"
"P-MTP00197854/03 X\n"
"P-MTP00197868/02 X\n"
"P-MTP00197882/00 X\n"
"P-HMF00197730 \n"
"WI/B09/077094 \n"
"Q-MTP00197735 \n"
"Q-HMF00199313/0 X\n\n\n"
"Q-HMF/23/00199313/0 X")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.