using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:(?!g1|g2).)*(?:g21|g22)(?:(?!g31|g32|g41|g42).)*(?:g11|g12)).*?(?:g11|g12).*$";
string input = @"'g11'
'g31 g11'
'g41g11'
'g11 g21 g11'
'anything or nothing g11 anything or nothing'
'anything or nothing g31 anything or nothing g11'
'anything'
''
'g31 g21 g11'
'g21 g11 g31'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}