re = /^(?!(?:(?!g1|g2).)*(?:g21|g22)(?:(?!g31|g32|g41|g42).)*(?:g11|g12)).*?(?:g11|g12).*$/m
str = '\'g11\'
\'g31 g11\'
\'g41g11\'
\'g11 g21 g11\'
\'anything or nothing g11 anything or nothing\'
\'anything or nothing g31 anything or nothing g11\'
\'anything\'
\'\'
\'g31 g21 g11\'
\'g21 g11 g31\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end