using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^"", -]*)\s*-\s*([^,"" ]*)";
string substitution = @"$2 $1";
string input = @"""Bjerre- Jonas, Jorgensen- Silas, Wohlert- Johan, Madsen- Bo""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}