$re = '/(?<=\d)\.0\b/m';
$str = '15.0+abc-3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;