#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(?:g31|g32)(?!.*?(?:g21|g22)).*?(?:g11|g12).*$"
Local $sString = "g31 a bunch of anything or nothing g11" & @CRLF & _
"g31g11" & @CRLF & _
"g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11" & @CRLF & _
"g31g21g11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")