import Foundation
let pattern = #":(laugh|mmmm|smile):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hey my dear :laugh: how are you :mmmmm: :smile: and non existing smile :go: "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="images/smileys/$1.png" class="$1">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)